2.0.50-beta.4 Pre-Release Available


#1

This release includes the following enhancements and fixes:

  • All features/fixes from v2.0.50-beta.2
  • Addition of Servo library
  • Fix issue with PWM duty cycle calculation
  • Fix issues #34, #35

#2

#3

Servo Library! Woohoo thanks Eric!! Can’t wait to start playing with this.


#4

Anyone have any feedback/concerns/issues with 2.0.50? We are on the verge of releasing this as the new default version, so please let me know if there have been any problems. Thanks!


#5

I can no longer compile via the Web IDE with 2.0.50-beta.4, even a blank project. Switching to a non-Bluz device allows the compile to succeed as does picking a different firmware version. The error returned after a long delay is Error: 404. Please try again later. If the issue persists, please report to hello@particle.io.

–Update: Particle says it’s on their side and they are investigating.


#6

Yes, I have contacted them as well, they should hopefully get that resolved soon. Sorry for the troubles.


#7

It’s working again, as of this morning.


#8

Ran into another odd issue; compiling with the beta firmware isn’t showing any error output when it doesn’t compile. For when I left off a semi-colon I got only this: Error: Could not compile. Please review your code.

Both beta versions did that but switching back to the latest non-beta and I was able to see the problem.

My second issue is that after fixing that problem I was able to compile with the latest non-beta plus the first beta but I still get the same ‘could not compile’ error with the latest beta version. Even compiling a blank program fails with 2.0.50-beta.4.


#9

Thanks, I am reaching out to Particle about the newest beta not compiling, I am seeing the same issue.

These new versions use a very new system on the Particle side, it allowed us to switch to gcc 4.9.3 and increase the user app size. It does seem to have a few kinks still, however!

Thanks for your patience.


#10

Sorry for the downtime, but the Web IDE should be working fine again for all builds.

Particle is looking into the issue and are getting the wrinkles worked out of the new system, I’m confident they will get it to a more stable state soon. Let me know if you have any further issues.


#11

Doesn’t seem to be working consistently. When compiling/verifying, Beta 4 times out more than half the time whereas Beta 2 and 1.0 typically take 3sec to compile and I haven’t seen them fail today.


#12

Sorry for the trouble. Particle is working to get this firmed up. I am personally not seeing any issues at the moment, so I hope your issue may have already passed.

Rest assured, this should only get better over time, just a few hiccups in their new system. Thanks!