Android App Beta Test


#1

While the iOS app is in the store, the Android app has still required some work after the beta period. While we are making progress, we also believe it is best to get things into peoples hands early, especially when it comes to Android as different handset manufacturers can reveal all kinds of fun new errors.

So, we are posting a build of the Android app in its current form in the hopes that a few people can test it and report issues. This is very early and rough around the edges, just trying to get some feedback and make sure it works on various handsets.

You can find the .apk file and instructions here: https://github.com/bluzDK/android-app-beta

Please let me know if you need any help or run into any issues. I will run this for a few days and try to gather some feedback and then we should be able to post it to the Play store later this week.


#2

Awesome can’t wait to give it a try… been so busy with work I haven’t had a chance to even think about my bluz! Hope to make some time this week while things are a bit slower.


#3

Hi, I installed the apk and when I press the connect button, after some time, the bluz led starts blinking in magenta.
Do you know what’s the problem.
I’m using a Nexus 5 device.
Thanks.


#4

So when you first power on bluz, the LED should blink slowly green. Then when you press Connect in the app, it should switch to quickly blinking green. Is this happening?

After some time does it switch to magenta? How long does this take? Is it about 5-10 seconds? Or more like 30-40 seconds?

Does the phone have a good strong internet connection? Do you happen to have access to an iOS device you could try?


#5

Just got the new app installed. I had to remove the old app before I could install the new one. Took me a few minutes to figure out… Now onto testing it :slight_smile:


#6

I only have an Android device…
After switch to quickly blinking green, it takes 30-40 seconds to switch to magenta.


#7

After about 20 seconds or so, does the device ID show up in the app on the device you connected? It is a long, hex string that starts with b1e2. Can you send that to me in a direct message?

What connection is the phone on? Cellular or Wifi?


#8

After pressing the connect button, the app is getting an ANR and I have to force stop it…
I can’t see any device id there.
My phone is connected via WiFi.

Btw, I don’t find any button to send you a direct message in this platform :confused:


#9

Ok, so it sounds like the app is crashing after you try to connect, yes? That would explain why bluz blinks magenta, that state basically means the handshake with the cloud failed which would happen if the app stopped.

What version of Android do you have?

So it sounds like the app has issued on the Nexus 5, and I have also heard issues with Samsung S6.

For the people who have tried the app so far, could you list the hardware you were using and if you were able to successfully connect? Also please also list the Android version.

I have tried a second gen Moto X on Android 5.1, and that works.


#10

Nexus 5, Android 6.0.1

Crash log:
02-23 23:38:43.588 12481 13125 W System.err: java.lang.NullPointerException: Attempt to invoke virtual method ‘void java.io.InputStream.close()’ on a null object reference
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.sparkle_gateway.ParticleSocket.Disconnect(ParticleSocket.java:59)
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.BLEManagement.BLEDeviceInfo.disconnect(BLEDeviceInfo.java:117)
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.sparkle_gateway.BLEService.handleNewState(BLEService.java:135)
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.sparkle_gateway.BLEService.update(BLEService.java:119)
02-23 23:38:43.598 12481 13125 W System.err: at java.util.Observable.notifyObservers(Observable.java:138)
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.BLEManagement.BLEManager.SendEvent(BLEManager.java:175)
02-23 23:38:43.598 12481 13125 W System.err: at com.banc.BLEManagement.BLEManager.updateState(BLEManager.java:123)
02-23 23:38:43.599 12481 13125 W System.err: at com.banc.BLEManagement.BLEManager.access$300(BLEManager.java:26)
02-23 23:38:43.599 12481 13125 W System.err: at com.banc.BLEManagement.BLEManager$3.onConnectionStateChange(BLEManager.java:200)
02-23 23:38:43.599 12481 13125 W System.err: at android.bluetooth.BluetoothGatt$1.onClientConnectionState(BluetoothGatt.java:181)
02-23 23:38:43.599 12481 13125 W System.err: at android.bluetooth.IBluetoothGattCallback$Stub.onTransact(IBluetoothGattCallback.java:70)
02-23 23:38:43.599 12481 13125 W System.err: at android.os.Binder.execTransact(Binder.java:453)


#11

Thanks, that is very helpful.

So just to clarify, this happened immediately after you clicked Connect, is that true? According to this log, it is going through the Disconnect process.

Let me see if I can get my hands on a 6.0 Android device…


#12

Yes, that’s true.
I’m an Android developer, If you need some help, please let me know.


#13

I had a very quick go this morning before running out the door… couldn’t get it to connect. Can’t tell you what the device was doing coz it doesn’t have the led :frowning:
Running 5.1 on HTC m9
Got a msg saying it stopped responding and asked to close the app


#14

@eric, I installed the 0.9.0 app on a Samsung Note 3 running Android 5.0.

  • On login scree, I enter credentials, hit “Login”, “Logged in!” pops up but the screen doesn’t return “home” (scan screen)
  • On the “home” screen, my bluzDK appears. If I hit connect, the fill around DK icon and the button goes blue momentarily and nothing else happens.
  • I can do this several times. If I hit the Stop button and THEN hit connect, it connects and the bluzDK comes online

:smile:


#15

Signs of progress at least, the app is 1-for-3 so far in getting a device to connect! At least it didn’t completely strike out.

Things seem to work OK on my Moto X, so I am digging some old Android devices I have out of the closet and will try and find one that upgrades to 6.0. My experience has always been the different handsets lead to different errors, so trying it on as many as possible and just trying to get to the root issue is best.

Thanks for everyone who is trying, and especially thank you to the folks looking at the code too!


#16

Mine is exactly the same as @peekay123 describes.

Good luck finding it… wish I could do more to help


#17

Hmmm… interesting.

@joaoglopes could you try that as well? Wondering if it would stop the crash on your phone or if that is a separate issue.

Thanks


#18

I have a Samsung Galaxy S5 and Galaxy S3. The S5 worked exactly as described by peekay123 with the same button sequence required. Android version is 5. The S3 screen just goes blank when you press the login, the Android version is 4.3


#19

After some awesome work by the community (thanks @joaoglopes!) I pushed up a new version of the app. There are still a few things to fix, and I will try and get those done quickly, but hopefully this should be a little more stable (and better looking!) than the last build.

Let me know how it goes!


#20

Nexus 6
Android 6.0.1

power on,
green slow blink
start app and click connect
green fast blink
after around 30 sec fast blink magenta.
short time after app crashes.

tried both wifi and mobile (cellular)

Prior to app crashing the connect button changes to disconnect.
app shows Bluz Dk icon with a - (minus) number beside it.
no other response from app

If relevant the bluetooth on android shows a device but does not pair. (if it should)

greetings