App(s) crash when attempting to connect. Multiple devices


#1

I received and started playing with my Bluz. I was able to blink an LED and communicate with it, then my battery powering the Bluz died. When I attempted to connect again, the app crashed. I did the following without success:

Restarted iPhone
Deleted app cache (double click home button, kill app saved state)
Thinking it was just the app, I deleted and re-installed the app.
Tried the beta Android version
Tried to install the app on a completely different iPhone (same result. app crash)

My Bluz is flashing magenta every second and a half or so.

I do not have a gateway shield. After searching how to connect to this manually and finding that it’s only possible through a mobile app, I’m feeling a bit frantic, as I have a project due Friday that was going to feature this unit and I’ve now lost all connection.

Thanks in advance.


#2

When you power bluz on, before you try to connect, what color does the LED flash?

We do have reports of the app crashing at times, it seems to be happening when bluz gets disconnected quickly after a Connect. I would say the issue has been intermittent and not occurring too often.

It sounds like your bluz may be in safe mode. This can be ok, if it blinks magenta when you turn it on and then it quickly blinks magenta while you connect and then blinks slowly once connected, you should still be able to see it online and lid code via the Web IDE.

If possible, can you DM me your device ID? I can look at the logs and see if I can spot somethings.