Bluz GW Shield works with Photon but not with Core?


#1

I dug up my dusty Bluz Gateway Shield and a Core for a new project, but as it seems I can’t get the GW to connect with the cloud (at least the bluz console doesn’t see it and the L2 LED goes into a steady blink - but the Core breathes cyan).
But when I flash the same Gateway.INO to one of my Photons things work as expected.

I’ve flashted both devices with Particle system 0.6.0.


Update:
After I updated the GW Shield firmware via bluz console and the Photon in it, the behaviour has slightly changed.
Now the L2 LED blinks about 3~4Hz with the Core breathing cyan in it, but bluz console still states

No gateway detected yet.


#2

The Core should be supported. I will have to dig mine out and give it a shot, if there is a bug there I will try to get it fixed. Thanks


#3

I am using a Photon currently because the gateway example in the IDE indicated it wasn’t compatible with the Core. Is this the case? I’d like to use my old Core and free up my Photon again.


#4

There seems to be a problem with the Core and the current gateway code. I am looking into this.


#5

@ScruffR and @mnetwork: I took a look at the issue. There was a really fun bug there where we had a macro named SPI_HEADER_SIZE, which just so happened to be the same name as a macro in the CC3000 library of the Core. It worked fine before we turned this into a library since it took the local definition, but once it became part of a #include call, then it broke everything. So renaming the variable worked.

However, I am still having issues. I am getting SOS codes when trying to connect devices, mainly an 8 code which means Out of Memory. So there is definitely some issues there and I am trying to figure out a way around it.

This did work before, so I am wondering if it is a version issue on the Core.

Hope to get more details back soon…


#6

Is there any update on this?


#7

Not yet, was busy getting the release out this week. I will try and circle back to this soon