Can't claim after reflashing firmware on Bluz

I have a Bluz that was on 2.3.50 but I mistakenly had the target set as 2.2.50 on the web IDE as I was working on a separate Bluz module that wasn’t as up to date. After it tried to flash this one with the older version, the Bluz stopped responding. The RGB LED would not light at all and it seemed dead. I was able to boot it into bootloader mode (hold BTN and tap RST) and then I reflashed the firmware via USB UART by running and specifying system-part1.bin and then tinker.bin (both from

Now the Bluz seems to “work” and blinks green every ~2 seconds. I can see it and connect via Android app (the green light starts blinking faster) but after ~30 seconds it pops up to claim the device again and when I click “Claim” it says “Error Claiming Device!”. I went into the device console online and unclaimed the Bluz there thinking it might be confused about the state but it still just says “Error Claiming Device!” any time I try to claim it now. I’ve tried on 3 different Android phones and they all act the same way.

Is there something else that I need to do after flashing system-part1.bin and then tinker.bin to “complete” the process? Thanks!

Can you send me the device ID in a private message? I can look on my end as to what account the device is currently claimed and we can try to resolve this for you. Thanks

Hi Eric, I believe I sent the ID in a private message the other day. If you did not receive / I did it incorrectly, please let me know. Thanks!