Can't flash firmware to bluz dk from Particle Cloud IDE?


#1

Hi there! new to Bluz.

I’m trying to flash some basic sketches to my bluz hardware (connected to the cloud via the gateway shield and a particle photon). I see the devices all online in the IDE, the code verifies successfully, but pressing the Flash button doesn’t do anything. No error, no loading indicator, nothing.

I’ve got experience with Photon, and I was also able to flash the gateway shield photon successfully. Just the bluz dk units don’t seem to be flash-able.

any thoughts? thanks!


#2

Welcome to bluz!

First, what version of firmware are you trying not to compile with? And what is already running on the devices? Is it the Tinker app that comes pre-loaded?

If it is running Tinker, could you try and change the pin on D7 to HIGH in the Particle app?

There should be a message in the IDE, it would say something like “Flashing code, if the LED doesn’t turn magenta then try again” or “This is taking longer than expected”. Do you see any of those messages at all?


#3

Hi Eric, thanks for your reply. I’ve tried setting D7 to HIGH in the particle app (which works fine and the white LED lights up on D7) but the IDE is still unresponsive.

Usually it says “Flashing code, if the LED doesn’t turn magenta then try again” or “This is taking longer than expected” when flashing a Photon or Core. works everytime. but not with either of my Bluz modules, it seems.


#4

Thanks. What version are you flashing?


#5

Also, can you PM me the device ID? Thanks


#6

Hi Eric, I’m flashing 1.1.47 to both bluz dk’s.

DMing you the device IDs too


#7

Hmmmm… I don’t see any obvious problems. Those device seem to be working properly and getting online. I tried the Web IDE for both 1.1.47 and the 2.0.50 betas and that is working fine, I can flash code without a problem.

Can you try connecting them through our iOS or Android apps and see if you can flash them that way? Also, can you try flashing just a blank app (empty setup() and loop() functions) when connected with the phone app? Just trying to narrow down the problem to the simplest scenario,


#8

Okay, I think I figured it out. I was using the On this device (1.1.47) firmware target, but changing it to 1.1.47 allows me to flash the device successfully. I wonder why that matters.


#9

Interesting. Let me run that one by Particle and see what they say. Glad you found a fix!