Can't get (new) USB gateway to join WiFi


#1

I’ve continued to have problems with the shield gateway going out in the weeds every few days. So…I ordered a new USB gateway and I can’t seem to get it to connect to my WiFi. It goes through all the steps just like a Photon, but gives me an “X” on the last step indicating it failed to connect to WiFi.

I also tried running “particle setup” from the CLI, but without success.

I have tried about a dozen times between USB and OTA.

Thoughts???

(updated) The specific error message is: “Setup process couldn’t disconnect from the Particle device Wi-fi network. This is an internal problem with the device, so please try running setup again after resetting your Particle device and putting it back in blinking blue listen mode if needed.”


#2

Are you trying to do this from the CLI? Did you try setting it up from the Particle app? Is the gateway still in blinking blue setup mode? The P1 in there is just a Photon basically, so you should be able to set it up the same way.

I do have some good news on the other front, I have spent a LOT of time trying to investigate your issue and I think I found a possible cause. It was a pretty strange race condition between the photon and nrf51, but I was able to catch the issue at least twice where the gateway hung and going to the dashboard brought it back. I also fixed a few other random issues that I found, so there is definitely some improvements to stability. I have been running a stress test on a gateway and 3 DK’s for a few days and haven’t caught the issue again, so I think it may be fixed. Give me another day or two and I can get you an update for your gateway to test.

Also, v2.0 will be ready soon and this has some features that will help you significantly increase battery life, so you should be able to get more life from your current setup.


#3

Hi @eric, I tried initially using the Particle app (many times), but without success. That’s where I got the message I posted–when it was sending my WiFi credentials to the gateway’s P1 and apparently getting stuck in the process.

I then tried via the CLI, but it kept reporting that the P1 was not getting connected to the cloud. Here’s that message: “! It doesn’t look like your Photon has made it to the cloud yet.” I can never get past that point.

So…I’m kinda stuck with the new USB gateway.

Ironically, about the same time, the shield gateway went out in the weeds. Whenever I find it in this state, the Photon blinking blue (listening mode) and the white LED is also blinking rather quickly. If I do a power cycle, all is well within a short period of time.

I’m so glad to hear you may have found the problem. Quite honestly, I was about to give up, but I’m awfully stubborn!


#4

I certainly appreciate your paience through this, needless to say this isn’t the experience we want any of our users to have.

For the gateway, how are you powering it when you try to get it on WiFi? Have you tried a different power source?

Does the P1 LED change from blinking blue at all during the setup process? Or does it always stay that way?

Also, from the CLI, are you able to issue ‘particle identify’ and see the device ID returned?

i am trying to dig through the Particle forums as well, see if I can find an answer. In the end, the P1 is supposed to act just like a Photon as we don’t do anything special


#5

I had it plugged into an iPhone USB adapter, my MacBook Pro and a third party USB adapter that’s rated at 5 VDC @ 1A. It doesn’t make a difference.

The blue LED never changes its blinking pattern–always stays in the listening patter. Now, it seems when I enter the WiFi password, the iPhone Particle app immediately complains with the message above. I did a hard restart on my iPhone just in case something was messed up in a buffer or somewhere and it had no effect on the process.

I did a ‘particle identify’ and do see the identity and the system version 0.5.1.


#6

I haven’t seen many references to this, but one suggestion seems to be to hit the reset button right after the app sends the credentials: https://community.particle.io/t/maybe-solved-photon-strange-behavior/14768

That sounds like an old bug, but there seem to be very few instances of that error showing up on the Particle forums. We don’t have a reset button on the gateway (there is a Setup button), so not sure if unplugging/replugging right after the app shows the error would help or not.

I assume you have the latest iOS app and don’t need an upgrade? As I mentioned, there is a Setup button if you need it, so you could try things like DFU mode flashing or setting it into safe mode, but I don’t know if that will help.

I will keep trying to look for an answer or ping someone from Particle if I can’t find one.


#7

I am running the current version of the Particle app. How would I get to the Setup button? Does the case pry open? I don’t want to break the thing [well…part of me does! :wink: ]


#8

You can pretty easily pop it open. Just place the gateway with the logo down, then stick a screwdriver in between the UCB plug and the case and slightly pry it up.

You need to then take out the two screws and the Aetup button is on the back.


#9

Is the code for the USB gateway the same as for the shield gateway?


#10

Yup, same code. The Particle sketch handles the difference


#11

Thanks. I’m just wondering if I flash (USB) new system software and/or application firmware, will the problem be mitigated. I still can’t get the USB gateway to behave.