Compile Error ( for BluzDK) in Particle Dev


#1

Hello,

I would like to ask for suggestions and possible solutions for the problems and limitations I am facing when it comes to compile ino files in Particle Dev app (Atom).

This is the error that I am getting.

I have to use ino files in desktop IDE because library files which I need, are not available in Particle Build (web IDE).

Some says targeting to latest BluzDK system firmware will solve that compile error.

But I need to stick to firmware 1.1.47 because the local communication does not work in higher version of firmware as I have checked in other topic.

Moreover, targeting to specific system firmware seems only available in web ide.

As I need to add more codes to add other functions, the above error is preventing me to do so.

I am aware that there is certain limit in program size that Bluz DK can accept.

But, in order for me to use local communication while having more functions (more codes), is there any option/solution ? :sweat:

Ps: I checked building firmware locally from here (which I think it can allow me to compile ino file locally) which involves commands in terminal such as git clone … , make… .
But these are way complicated for me as there is no straight forward tutorial available for Bluz. I keep getting the errors. such as error2.

Thanks in advance.


#2

Local communication is working in 2.1.50, I just tried the example and it is working fine. What problems are you running in to? Are you not seeing the device connect? Or not seeing the device data show up in Console?

Is your gateway up to date with the latest firmware? You can check that by visiting http://console.bluz.io/ and signing in with your Particle account.


#3

I will update here later on.

Even upgrading process is giving problem.

Connected with Bluz App to upgrade yet there is an error.

I will try again tonight.


#4

There is a very strange bug I am trying to track down where OTA updates can sometimes get stuck. I have been trying to fix it for nearly 2 weeks now, and it is very very difficult to track down as it is very intermittent and hard to reproduce. I can’t explain it yet, but rest assured I am trying as hard as I can to get it fixed.

In the meantime, simply trying the update again should work. I will get this issue resolved as soon as I possibly can.


#5

Successfully upgraded to 2.1.50 to BluzDK. Local communication is now working. One problem solved, another problem comes in.

Now, the issue is that flashing code via Particle Dev no longer works. :frowning: I can see the magenta flashing on BluzDK while I update from Particle Dev. But I see no changes in output. Previous code flashed via Web IDE remains intact. Flashing from Particle Dev cannot override the existing code. I have tried compiling and flashing from Mac and Windows version of Particle Dev. The issue still persists.


#6

This sounds like a version issue. When we released 2.1.50, the boundaries of the firmware modules changed. So the user app gets downloaded to a separate spot in flash in 2.1.50 then it did in 1.1.47.

It sounds like your system firmware is 2.1.50 but you are still flashing apps built with 1.1.47. This would copy the user app to the wrong location and the system firmware would never get updated.

You mentioned you are using the local dev tool, are you sure it is compiling with 2.1.50? If you flash code from the Web IDE compiled with 2.1.50, does that work?


#7

How can I check the version of BluzDK from Particle Dev?

Is it from here?

I tried pressing that icon, but no result is coming up in both Mac and Windows version of Particle Dev.
Seems like that is the bug in local IDE.

Update : Tried on Particle Cli, it does not flash successfully either.


#8

We haven’t done a lot of testing with the local IDE, and I am not terribly familiar with it. Perhaps some of the @particle people here may know better?

pinging @peekay123 @AndyW @ScruffR


#9

Tried a few times, still no success for flashing from Particle Dev and Particle Cli.
Guess time to ditch the current BluzDK and buy new one. :neutral_face:


#10

Yeahh!!! After scratching my head and tried several times, it is now working with Particle CLI. :blush:

This does the magic.

$ particle compile bluz --target 2.1.50
$ particle flash --target 2.1.50 device_ID firmware_name.bin


#11

Great, glad it is working. And good to know about the --target option!


#12

After successfully flashing the experimental code to BluzDK, it intermittently disconnected and reconnected to the cloud until the point where I cannot flash new code anymore as its “online” time is just not long enough to flash new code.
Then I factory reset it. Connected with my bluz app to upgrade to new firmware. Things got crazy while BluzDK was upgrading. In the midst of upgrading, RGB light on BluzDK not flashing anymore.
I tried pressing two buttons together hopefully to reset. No luck. I think my BluzDK got bricked. :sob:


#13

What code were you running? Is it possible to post? It is possible to block cloud operations if the setup or loop functions block. Bluz is single threaded, so blocking any portion of your app will stop the cloud functions, including OTA updates, from working.

Can your board enter bootloader setup mode? You can see how to do that here: http://docs.bluz.io/tutorials/bootloader/#entering-bootloader-setup-mode


#14

I DM-ed the code to you.
BluzDK cannot go into bootloader setup mode.
RGB light is not even turned on when I power up from Battery shield. Guess I am out of luck.:disappointed_relieved: