Do I have a defective DK Board?


#1

On powering my DK, there are no lights.

I factory-reset the board but I never get a flashing blue (even though the board

connects to the cloud).

I tried re-flashing a program, the browser shows that is is flashed but I am still never getting a flashing blue like I used to. Now, I am not even getting any lights although I can still reset the board.

I had the same problems a few months ago but somehow the board started working again. I have another board on order but hoping to do some work while the new one arrives …

Is this board defective and should be discarded?


#2

What code are you using? Does the code control the RGB LED at all? The user code can turn it off.

If you see it connecting to the cloud in the dashboard, I don’t think there is anything wrong with the board. It could be possible that the RGB LED is somehow damaged, do you see it flash any color at any time?


#3

Thank you @eric. I am running a simple sketch that does not control any pins or the LED. The code just reads from a sensor connected to Serial1.

The RGB LED always shows the correct colors when resetting including the flashing green. It just never goes to a flashing blue and more importantly does not run the code. The same code runs fine on a photon. BTW, the code also does not use any Photon-specific libraries.

Now, I am not getting any light from the LED. The same happened last time I used it (months ago) and I had written to you about it but then somehow resetting the board worked at that time.


#4

When you say reset, I assume you are performing a factory reset?

How are you trying to connect the device to the cloud? App or gateway?

Can you send me the device ID of the board?


#5

Thanks @eric.

Yes, I am performing a factory reset.

I am connecting to the cloud via an iPhone.

Device ID is b1e2498099ac7bcc040efe56


#6

Sorry for the delay.

After a factory reset, it seems the board reverts to an old version of firmware. The Particle Web IDE should then prompt you that you need to upgrade to v2.0 of our firmware. Do you see this happening in the Web IDE when you try and flash an app after a factory reset?

Looking at the logs, it seems the board is in some kind of safe mode loop. Getting the Web IDE to prompt you to upgrade should correct it. Perhaps after factory resetting and connecting, can you refresh the Web IDE? In the devices tab, you should then see it says you are on firmware version 1.1.47 (or 1.0.47). If you then try to flash an app with version 2.3.50 you should see a prompt to upgrade. Do you see this?


#7

It says my board has firmware 2.1.5.

I have never been able to flash anything else despite trying. I also never get a message to flash 2.0.

I am assuming this means the board is defective? I bought another board which shipped yesterday …


#8

Hmm… Looking in the logs, it would appear the board has an older version of firmware after the reset. When did you purchase this board? Was it more than a year ago?

I don’t think it is the board, the cloud seems to be having trouble recognizing the correct version of firmware on this one, and therefore it isn’t giving you the proper dialog to upgrade. Either way, we will replace it at no charge, this isn’t the kind of experience we want our customers to have. If you can email me at hello@bluz.io, we can work out the details. Thanks, and sorry for the trouble.