Factory Reset Recovery Fails (using OTA)


#1

Despite precautions I got into the “solid white” state.
I seem to be able to get into safe mode reliably (colours as per doc then magenta flash about 2 sec period).
Then I try to flash something (via either IoS or Android gateway) using either web IDE or desktop CLI.
After that I get this:

{"name":"spark/safe-mode-updater/updating","data":"1","ttl":"60","published_at":"2016-08-16T16:02:27.607Z","coreid":"particle-internal"}
{"name":"spark/flash/status","data":"started ","ttl":"60","published_at":"2016-08-16T16:02:29.849Z","coreid":"b1e243bbb4..."}

Magenta flash still happening.
Then nothing happens for 10 mins and we get

{"name":"spark/flash/status","data":"failed ","ttl":"60","published_at":"2016-08-16T16:12:29.850Z","coreid":"b1e243bbb4..."}

During this time the phone app shows that it is still connected.
Meanwhile the IDE or CLI shows that flashing the device has failed.

I’ve checked the voltage on the v3.3 pin and am at a loss as to what to try next.


#2

Sorry for the delay. Is the issue still happening? Once the update starts, when you see the event from the cloud, what is the RGB LED doing? Is it blinking or just off?

Does the gateway have a reliable internet connection? Is it on cellular or wifi?


#3

It now appears to flash a sketch and then starts safe-mode-updater
Solid magenta.
After 10 mins we get the failed message above
Still solid magenta.
The tried factory reset again. Gets back to flashing magenta.
Tried to flash again.

"2016-08-19T10:50:10.156Z","coreid":"particle-internal"}
{"name":"spark/safe-mode-updater/updating","data":"1","ttl":"60","published_at":"2016-08-19T10:50:10.178Z","coreid":"particle-internal"}
{"name":"spark/flash/status","data":"started ","ttl":"60","published_at":"2016-08-19T10:50:11.153Z","coreid":"b1e243bbb4d..."}
{"name":"spark/flash/status","data":"success ","ttl":"60","published_at":"2016-08-19T10:52:26.177Z","coreid":"b1e243bbb4d..."}
{"name":"spark/status","data":"offline","ttl":"60","published_at":"2016-08-19T10:52:27.116Z","coreid":"b1e243bbb4d..."}
{"name":"spark/status","data":"online","ttl":"60","published_at":"2016-08-19T10:52:49.983Z","coreid":"b1e243bbb4d...}
{"name":"module-info","data":"{\"m\":[{\"f\":\"b\",\"n\":\"0\",\"v\":\"6}{\"f\":\"s\",\"n\":\"1\",\"v\":\"4}{\"f\":\"u\",\"n\":\"2\",\"v\":\"5}]}","ttl":"60","published_at":"2016-08-19T10:52:50.666Z","coreid":"b1e243bbb4d..."}

(during this time the factory reset must have taken place)
now flashing cyan
left it for a while…
no more notifications seen
still flashing cyan
eventually pressed reset
flashing green, faster green then back to cyan

{"name":"spark/status","data":"offline","ttl":"60","published_at":"2016-08-19T12:53:30.020Z","coreid":"b1e243bbb4d..."}
{"name":"spark/status","data":"online","ttl":"60","published_at":"2016-08-19T12:53:41.151Z","coreid":"b1e243bbb4d..."}

OK. So now we are back to being able to flash apps.

Flashing cyan confused me initially. Now I realise that I had checked the option in the iOS gateway app to reconnect automatically.

It seems that I got into this mess by being impatient with the factory reset process. I think it would be good in a future version to have more explicit messages to show what’s happening.

After that I broke it again (a particular app seems to do this)
Magenta flashing. Can’t flash an app. Repeated process above and resolved it after 2 tries.

I have the impression that the time to action a factory reset is unpredictable and highly variable.