Gateway not showing up in console.bluz.io


#1

I have an older Gateway that I am sure needs a software update. When I go to console.bluz.io I am not seeing any gateways listed.

I am looking at the console and eventually I get a timeout error:

Error: Request Timeout at Request. (http://console.bluz.io/js/particle.min.js:502:2177) at Request.Emitter.emit (http://console.bluz.io/js/particle.min.js:504:1072) at XMLHttpRequest.r.onreadystatechange (http://console.bluz.io/js/particle.min.js:502:7391)

HTTP error 408 from /v1/devices/b1e…/version

Also in the Console I see a Devices: log message where I am able to see the devices associated with the account. It seems like the webpage is correctly fetching the list of devices, but failing to request the version.

Could the service just be partially down?


#2

Is the gateway device connected to the cloud? Is the white LED blinking once every 2 seconds?

Also, is the Photon/P1 claimed to your account?

You can also try ‘particle list’ from the CLI. You should see the gateway listed there wth a few functions for getting the version.

I just tried my gateways and see them correctly listed, so I don’t think the service is down.


#3

Both devices are online and claimed to the account.

The console.bluz.io site actually worked just before in order to claim the Gateway. It was operating for awhile with just the P1 claimed.

I tried particle list and that is showing both sides. The setGWTarget is missing which proves the firmware is older. Any other ideas?


#4

When I try from the CLI

particle get ID version

That returns a timeout as well. Perhaps the Gateway is in a bad state? Unfortunately the Gateway is not at this location. I will have it rebooted tonight and try again tomorrow.


#5

I rebooted the gateway and it still has trouble reading the version from the bluz portion of the gateway. It just times out when trying to read version.

I can read gatewayID from the photon side. Have you ever seen a gateway get into this state?

What do you think is the best way to get this gateway to behave?


#6

Is the gateway in safe mode? If you watch the dashboard on Particle when it comes online, does it state that it is in Safe Mode?

Do you know the device ID of the BLE portion? Can you PM it to me?


#7

I am not sure if it is in safemode, it is at a remote site. I just PM’d you the ID. Thanks.


#8

Hmmm… the logs seem to indicate that the device hasn’t come online since yesterday at just after midnight. I can see there is a pretty old version of firmware, and the device does indeed seem to be unresponsive.

Can you try one thing? Flash the Photon/P1 with the same gateway app (or new one, really doesn’t matter). That should reset both the Photon/P1 and the nrf51, forcing it to reboot and reconnect. Once you do this, you can watch the device connect in the dashboard and then wait for the Photon/Pq to publish it’s device ID (should happen a few seconds after it comes online) and then try to go to console.bluz.io right away.

The device does come online, so it must be working.

Is the Photon online? There was an issue in an old version of the gateway where if the WiFi cut out for 60 seconds the Photon would go into listening mode. The new version of the gateway library will fix that. If the Photon is online, I would try the above.


#9

I flashed the P1 part with the latest gateway code in the Build IDE and updated it to 0.6.0, but the bluz portion is not coming back online. I am not seeing anything related to it in the logs, and it shows offline when I do ‘particle list’


#10

I’m not seeing any obvious reason the device isn’t responding. As long as the code on the P1 is setup properly, then it should be ok. It was connecting properly before, so I don’t know what may have changed.

Are you able to get to the device to see the LED’s? That would probably be the best way to figure out the issue.


#11

How is it going with that gateway? Any luck finding the cause?


#12

Hi Eric,

I gave up on that Gateway for now.

However, I am now having trouble with a brand new one. I successfully claimed it with a Phone, and then attempted to update the software from the bluz console and it is now in a bad state.

It will eventually blink blue when I turn it on, but I can’t find it via wifi in my phone and it won’t go online.

Is there a way to do a factory reset on the P1 version of the Gateway.

Also, is there a way to update to the latest firmware on the Gateway over USB without claiming it first? When I give the Gateway to a customer I want them to have the best experience possible. Ideally I would update it to the latest firmware and set the gateway target ID myself, but have it still be unclaimed so they can easily go through the claiming process.

Thanks!


#13

Yes, you can get the P1 into any mode you want, but it involves opening the case. The case snaps together, so you need to pry it apart, I find the best way is to wiggle a screwdriver in between the case the the USB port.

Once it is open, there are two screws holding the PCBA in place. Remove those. On the underside, there is a button, this is the equivalent of the RST button on a Photon. Hold that down, then plug in the gateway to your PC and wait until the LED flashes Yellow. Once it does, it is in DFU mode and you can flash firmware via the CLI.


#14

Cool, where I can I find the latest official gateway firmware?


#15

For the P1? You can use the bluz gateway library as defined for the gateway shield: http://docs.bluz.io/tutorials/gateway_getting_started/#gateway-setup

The firmware is the same if it is the gateway shield or the gateway, so you can use that in the Web IDE and then download the binary that you build for the specific Photon firmware version you want to use.


#16

Thanks, I have the gateway all updated, version 0.6.1, and the latest gateway app built online.

I just can’t get this device to go online. I have tried ‘particle serial wifi’, and it doesn’t work.

I can’t get my phone to connect using SoftAP. Sometimes it just shows an error, other times it prompts for a password.

I have tried holding down the button for 10s to clear all wifi credentials. I have tried sending my key back up to the particle cloud.

Any tips on troubleshooting this guy?

Thanks!


#17

So the P1 is operating normally (when you try to enter various states with the button, it seems to do the right thing), is that correct? You just simple cannot get the WiFi to connect?

Is it just not exiting listening mode (blinking blue)? Have you tried setting the WiFI credentials through the CLI?


#18

Yes, the P1 is operating normally. I can do all ‘particle serial’ commands no problem. I can get it into DFU mode. I can clear the wifi credentials. The only thing I can’t do is get it to go online. After entering wifi credentials using the CLI, it blinks cyan super fast and doesn’t actually connect.

I am starting to think I might have a network problem, or that perhaps our IT department has blocked something. Although, I do have other gateways on the same network…

I am waiting to hear back from IT.


#19

I got it working. Sorry to trouble you. IT blacklisted my gateway…:rage: