Gateway Shield Connecting Issue with Core


#1

Hi @eric and community.

I’ve been working on the Gateway Shield firmware to make it support other BLE peripherals.

I recently flashed a version of the Firmware that had an code bug. I could not connect the Gateway to the cloud after this so I could not correct it. So I had to factory reset the Gateway.

Now as I boot up the Shield never connects to the Cloud and the Particle Core seems to be in a weird state (I power up, the Core connects and breathes blue, the Gateway L2 blinks to indicate it is connecting and then the Core suddenly disconnects and goes to flashing green and then reconnects to the Cloud. This cycle then continues).
See video here:
https://vine.co/v/5qwMLqKuw79

Here is the log from Serial after bootup until the Core acts weird:

I’m thinking that the Factory reset didn’t work (I’ve tried a few times) and my code issue is still causing this weird state.
(I believe there is an issue here with Factory Reset - I touch D6 and then Grd and reset, L2 blinks rapidly, I hold for 15 seconds and release Grd, D7 stays on steadily for 15 seconds) Everything is supposed to reset then but I think it’s not as the Cores lights are is the same state as when the D7 goes off, whereas if it resets it should go back to the usual Core bootup LED sequence)

is there any situation where a Factory reset can fail or can you spot anything wrong in the log?

The Core itself works fine. I’ve taken it out of the Gateway and tested it with other apps.

Thanks very much,
Mark


#2

That log doesn’t make me think there is something wrong with the gateway shield. The last command seen is the Core attempting to connect the TCP socket for the gateway shield. That, for some reason, appears to hang.

What code are you running on the Core? Is it the latest our repository: https://github.com/bluzDK/particle-gateway-shield-code

If possible, do you have a Photon? Can you try the latest library in the Particle Web IDE with a Photon?


#3

Yep, I have the latest particle-gateway-shield-code. I also reinstalled the .ino to be sure.

It’s still stopping here:
78385:DEBUG: Connecting Client3

And then the Core seems to reset (the Green LED starts to blink)

I think the firmware reset on the Gateway is failing. As after the L2 turns solid for around 15 seconds the board is not restarting like it should?

Think makes me think my old buggy firmware is still running.

Will keep trying. I don’t have a Photon but have an Electron on the way. Will buy a Photon soon.


#4

All ok @eric

You were right, this was a problem with the Core.

I took out the Photon from my friend’s internet button and used that, and it worked.

What’s unusual is that the Core was working fine with my Gateway right up until last Saturday. After this it started to hang when the Gateway was talking to it. The Core also works by itself (when I test it with my other apps). Wonder if this is caused by some issue/upgrade in the Particle cloud.

Anyhow, I will only be using the Gateway Shield with the Electron/Photon in future.

Thanks,
Mark


#5

I will go back and test the code with the Core before the next release, had slipped off our radar a bit but we’love correct it