Neopixels library!


#1

So there was a library posted here:

I know we had issues before getting neopixels and bluz working well when BLE was connected. However, I just tried this all again and made a few very minor tweaks, and it all seems to work great, even with 1.1.47. I tried with a 12-pixel ring and you can see the results here: https://vimeo.com/174036342

Things seem to be working just fine. I published the library to the Web IDE (believe it or not, this was the first time I did that! so let me know if I screwed something up :smile:) and would love it if a few others could verify this so I am not just going crazy here.

The example in the library will NOT work until and unless you connect bluz to the Particle cloud. So you need to be online for it to work properly. I can fix that moving forward, just wanted to get a baseline working for now. So just make sure you are online and connected to the Particle cloud.

Tagging @wgbartley since I know he was most interested!

EDIT: The name of the library is neopixel-bluz. I don’t see it listed yet, does it take a little while for the Web IDE to upload new libraries? I published it and it says Public, but I don’t see it when I search…


#2

#3

Is anyone else able to see the neopixel-bluz library in the Web IDE? I can’t find it when I search for it. Pinging @Aces since I know they have done this before but I m relatively new to it!


#4

@eric, yes, I can see it on the IDE. I searched for “neo” which lists all available libraries and the last is the NEOPIXEL-BLUZ. :slight_smile:


#5

yep i can see it too