Photon as gateway


#1

Hello,

I have particle photon already and was wondering how I can use it as a gateway so I don’t have to buy a gateway shield. I found a gateway.ino file on the particle IDE but I would think you have to have some communication between the 2. What pins on the photon and bluz need to be linked together?

Also, after flashing bluz I want it to be a solitary device not connected to the cloud, only locally connected to a phone app. Does it always need to communicate with the cloud?

thanks
josh


#2

You want to use a DK as the BLE portion of the gateway? Is that the idea?

That is technically possible, but the firmware would need to be changed on the board using a JTAG programmer. You would also probably need to change the pinouts in the firmware and recompile it. So it wouldn’t be straight forward but you could do it. If you have the right hardware and want to try, let me know and I can send more detailed instructions.

As for the local communication part, you can look to this part of our doc: http://docs.bluz.io/tutorials/local_communication/


#3

Not quite what i had in mind. The gateway that you can buy has a photon in it. I already have a photon so how do I connect the bluz to a photon on a breadboard to use my photon as a gateway.

The reason for this is, I am having issues with using my phone as a gateway. My nexus 5x running oreo can see the bluz and “connect” to it but it never makes it online. My old Moto play running 5.XX can do it but then it times out after about 3 or 4 minutes.

thanks


#4

For Android, can you try the fix listed here: App Fix for Android 7

We haven’t released this to the app store yet due to a few other concerns, but if it works for you that is one more data points for us. Let me know.

As for converting a Photon to a gateway, the easiest way is to get a gateway shield. It does not come with a Photon, the store just has it pictured with one.


#5

Hello,

Just tried the updated app and still no go. It looks like it can connect but still cannot flash anything.

Also if I try and update the firmware (2.1.50 to 2.3.50), it will not do it. I have to put it in safe mode and try flashing the same app in the current firmware version to get it to come back on line.

thanks
josh


#6

What happens when you try to update from 2.1.50? That doesn’t sound like it’s an app issue. Can you explain the steps and the outcome?