Problem with battery shield


#1

I just opened my Bluz and battery shield today for the first time. I seem to be having trouble with my battery shield. Here’s what’s happened so far.

I put the Bluz on a breadboard and powered it via 3V3 from a Photon. This worked fine. The board powered up and I was able to connect to it via iOS app, claim it, and see it in Particle web IDE. So that board seems ok?

I put a new CR2032 into the battery shield by itself, turn it on, and the white power LED lights up. I turn it off, put the Bluz onto the battery shield, power it on–Nothing. Not even a power light! Pull the Bluz off, power light comes on just fine. I checked the voltage of the CR2032 and it’s 3.29V.

Is my battery shield defective or am I missing something?

Thanks in advance. :slightly_smiling:


#2

That is strange. Can you measure the voltage across 3V3 and GND when the battery shield is powered on without bluz?

Can you try turning off the Power LED by flipping the jumper switch on the PCB?


#3

Is the jumper switch the small block with orangish tape on it between the female headers? Do I have to remove that orange tape to toggle it off?

I will measure the voltage shortly.


#4

Yes, that is the jumper switch. You don’t need to remove the tape if you don’t want to. The easiest way to flip that is to grab a pair of tweezers or something with a sharp end and just slide it to off.


#5

2.76V with power light on w/o Bluz.
3.07V with power light off w/o Bluz.

What should a CR2032 read when brand new both on it’s own and in the battery shield?


#6

Hmm… that should be fine. A new battery usually measures around 3.1V or so.

That is very strange, the battery shield is pretty simple and as long as bluz is working ok with another power source, I can’t see why it would cause this issue. Do you have any other battery source you could try? Any AA battery holders or something similar?

We can certainly replace the shield if it is faulty. Can you email us at hello@bluz.io and we can get you a new one?


#7

I have some AA battery holders. Are you suggesting I temporarily connect 2x AA to the battery shield CR2032 contacts?


#8

No, I was suggesting connecting the AA battery directly to the 3V3 and GND pins of bluz. I am just curious if perhaps there could be a short on bluz that is causing high current draw, the voltage across the CR2032 will quickly drop if there is too high of a load. If there is a constant power source, like the Photon, it may not be noticeable, but on a battery it would be. Just wanted to try and narrow down where the problem is.

Could you measure the voltage across the CR2032 when bluz is plugged into the battery shield and powered on?


#9

Ok, I connected 2x AAs (both brand new) to the Bluz GND and 3V3 and it powered on, I connected to it over BT (iOS app), and it started blinking cyan.

I will measure with the bluz on the shield next. These CR2032s are still new in the package, but the package is a few years old. Possible they read 3.3V but sag under load due to age?


#10

With the Bluz mounted, the CR2032 measures 1.40V. :fearful: 50% drop under load!

So I assume this means buy some new CR2032s and try again?


#11

Could be, though I would assume there would also be a large drop in voltage when the LED was turned on. When bluz first turns on it is in advertising mode so the power requirements are at the highest level, could be that it is the battery.

If you can get some more easily, it would be good to try.


#12

I will try some new CR2032s and update this thread once I get them. Thanks for your help! :smile:


#13

Ok, the brand new Sony brand CR2032 seems to have solved it. Thanks, @eric.