[SOLVED]Cannot connect Bluz via Android Gateway App


#1

I am trying to connect my Bluz to the cloud, but am not having luck. Months ago when I first received the board I was able to connect and claim it, but now it just disconnects when trying to connect. I have now done a factory reset and unclaimed the device with the same result. Here is where I am at now:

-Launch Gateway app
-Power on Bluz
-Bluz blinks slow magenta
-Bluz appears in app
-Hit connect on app
-Bluz starts a fast blue blink
-Claim button appears in app
-Hit claim and get “Error claiming device”
-App then shows Bluz as disconnected
-Bluz starts a fast magenta blink

Not really sure where to go here.


#2

I am indeed not seeing the device connect to the cloud.

Before you performed a factory reset, what was the status of the RGB LED when you tried to connect? Did it go from Green to Cyan? Or Green to Magenta? Or Green to Blue to Magenta?

What Android device do you have? What Android version? Was this the same device and OS version that you used to successfully connect devices before?


#3

From what I remember it was Green to Magenta. I am using a Note 3 with Android 5.0. Same device and ROM when I originally claimed the Bluz DK.


#4

Could you try rebooting the phone and connecting again? On some Android devices, the BLE stack has seemed to get get in a bad state, this can help.

Beyond that, do you have access to any other devices that you could try? Such as another Android or iOS handset?

These types of problems almost always come down to a problem in the gateway, or corrupt keys in the DK. Since you were able to connect to the cloud before, I don’t think the keys would be a problem.


#5

I tried resetting the Android device after creating the thread. Same result. I unfortunately do not have access to another device at the moment, but this is literally the same device I used originally. Would a catlog from the device be useful?


#6

It could be possible that another app is interfering, it may be waiting for BLE devices to connect and then polling them for data. I haven’t seen this exact case before, but it was something we were always aware of. Have you installed any apps on the device that would try to connect to BLE devices recently?

To cover the other path, do you have a USB to Serial adapter? We could try resetting the keys, just to make sure that isn’t the culprit.


#7

I was able to find an old iPhone 4S and that seems to work.

All is well on this front. Thank you, Eric!


#8

I’m having the same problem. I get to the point where I’m supposed to claim my device and get the error message “Error Claiming Device!”. For some reason, I thought that factory resetting it would help but I think that just made it worse.


#9

What Android OS and handset are you using?


#10

Android 4.4.4 on a Samsung Galaxy S4 SGH-M919


#11

Also just tried on my Galaxy Tab4 running 5.1.1 and getting the same error.


#12

Just to make sure, have you logged into the app with your Particle account?


#13

As far as I can tell. I mean, I’m able to log into the Bluz Gateway without any issue.


#14

When you say you can log into the gateway, I’m not sure what you mean? The app requires you to log in with your Particle account to claim devices, there is a button at the top of the screen.

There isn’t a way to log in to the gateway, so I’m a bit unsure what you mean? Please let me know, happy to help!


#15

When I open the Bluz Gateway App, I use my Particle login and password. That takes me to the screen where I Bluz Gateway App has no problem finding and connecting to the Bluz DK. Then, when I click “CLAIM” that’s when I get the “Error Claiming Device”. I would think that if I didn’t have a login & pass, I wouldn’t even be able to get to the point of connecting the App to the Bluz DK.


#16

What are the first 8 characters of the bluz device you are trying to connect to?

It should be b1e2XXXX where XXXX are hex characters. I can try and lookup any reason that you wouldn’t be able to claim it


#17

b1e246f1 I tried claiming it again this morning and still the same result.


#18

Looking at the logs, this device hasn’t been online at all in the last week or so. So it looks like the device isn’t online, but you are still getting a Claim button. This would certainly cause an error as Particle only allows you to claim online devices.

What does the RGB LED on bluz do? Is it blinking cyan?


#19

No it is only flashing magenta once I did the factory reset…which I mentioned before may have been a mistake on my part. Are there any actions other than completing this to creating a Particle account? https://build.particle.io/signup
(of course followed by confirmation email)


#20

Do you remember what the device did before you did a factory reset? Did it ever blink cyan? Or would it go to magenta only?

Any chance you have access to an iOS device? Or do you have a bluz hardware gateway or gateway shield? It sounds like the issue is that it never connected to the cloud, even before you did a factory reset. This is usually an issue with the gateway or the keys.