[SOLVED]Cannot connect Bluz via Android Gateway App


#21

No, it never blinked cyan. Before I factory reset it, I could get as far as connecting the Bluz DK to the app indicated by the LED quickly flash green. I would then go to claim the Bluz DK and the LED would switch to flashing magenta followed by throwing the same “Error Claiming Device” message.

I do not have a iOS device nor the gateway shield.


#22

It sounds like the app is the issue. I will try some debug steps here to make sure, but this particular device was tested before it was shipped (we test about 30-40% of devices before they ship as part of our QC) and this one connected without issues. It sounds like it never connected for you, which points to the app.

I have had various reports about issues with Samsung devices, but nothing that wasn’t ultimately fixable.

Just to make sure, the Android device has a proper internet connection?


#23

Yes, where I’m located, the 3G/4G signal is bad so I have a decent wifi setup at home. The Android device is connected to that wifi.


#24

Hi @eric , i have exactly the same problem as @EvelOtto … i received my bluz dk yesterday, and when i followed the getting started tutorial for connecting and claiming the device from the app (android version), i found that, after LED quickly flashing green, the LED changed to slow magenta instead of changing to a slow blinking cyan color. after that i made a factory reset, thinking that it could help, but now the LED is always blinking slow magenta … ANY HELP WILL BE APPRECIATED.


#25

What Android handset and version are you using?

In case anyone else finds this thread, factory reset won’t help this situation. For some reason, it seems the Android app isn’t working, so the issue seems to lie there and not with the DK.

If you have access to an iOS device (or even another Android device) could you try that? Also, make sure that the Android phone has a reliable internet connection.

I am not able to reproduce this on the devices and versions I have, but will try and round up the troublesome handsets and test it. This can be a hallenge with Android sometimes, every phone and OS can be very different and it is hard to test for all combos. I apologize for the troubles and will try and get to the bottom of this as fast as I can.


#26

@fbtobajas @EvelOtto: Ok, I know what the issue is, sorry for the delay.

The app in the app store had the IP address of the Particle cloud hard-coded. This shouldn’t have been that way, we must have uploaded the wrong binary file. Somehow, the fix was never checked in or accounted for as we discovered and fixed this long before release.

It worked fine for a long time, but now Particle must have changed their IP address. So, we properly set it to the domain name in the app and the issue is fixed.

The app is being updated in the store to version 1.1, so you can wait for it to go through the process and update your app (should be a few hours). Or, you can download the .apk file directly from here: http://bluz-scratch.s3-website-us-west-2.amazonaws.com/bluz-android-1.1/app-release.apk

Sorry about this, I had the new app on my test phones and the one on the store was the wrong version. Just an oversight that caused the issue, so I do apologize.

Let me know if you have any other issues after you update the app.


#27

Hi eric, i will try it … sorry for the question, but must i do anything
after factory reset to try again to connect and claim the device from the
app (since it blinks slow magenta after i performed actory reset)


#28

No, you should be fine. Once you get it online, it will still blink magenta. Go to the Web IDE and you should see the device as online (and in Safe Mode with a magenta LED next to the name) and flash an app. If you flash it with an app built with the same firmware version (likely v1.1.47) then it will exit safe mode after the update.

If you choose a new firmware version, then it will still be in safe mode, but the cloud will auto-update the system firmware on the next cloud connection.


#29

… ok, but first i have to claim it. Hope i can do it. Thanks


#30

That shouldn’t be a problem. The reason you couldn’t claim it before was because the device simply wasn’t online. Now that the connectivity issue is fixed, you should be able to get it online and claim it.


#31

Hi @eric … apparently i could claim the bluz, since it appears on my device list from Particle IDE. However, the led on the bluz is always blinking Red+Blue (i see 2 small leds blinking), with no sequence … which is the problem? thanks


#32

Hi again @eric … done. i flash an app and it works ok. thanks


#33

Success! Thank you for taking the time to look into my problem!


#34

The Tile app works this way and interferes with connecting. I was stuck on mostly slow green until I uninstalled the Tile app.


#35

I just got my Bluz DK and I have been unsuccessful in getting the android app to connect.

I can get it to show up in the app, but clicking the connect button just changes the text to “connecting” for a few seconds then it switches back to “connect”. Also, where I assume the device ID should be there’s a changing negative number (goes from -53, -50, -56 etc.)

It flashes blue slowly after attempting to connect it.


#36

I’m using a Samsung Galaxy S6 that’s running Android 6.0.1.


#37

Did you happen to try the app here: App Fix for Android 7

There was an issue in Android 7, it could be affecting you as well. Please let me know if that works


#38

I actually did give that a shot - it fails to install on my phone. So no cigar there.


#39

Do you have any other apps installed that use BLE devices? We have rarely seen conflicts where they can try and talk to bluz and interrupt cloud communications.

What happens when you tried to install the app from the link? You can try uninstalling the bluz app from the store first, that could help


#40

Hey Eric,

I tried uninstalling the app first, as well as clearing the cache etc. of the app.

When I try and install the version from the link it sort of silently failed with an “Installation Failed” message; no other error messages are given.

As far as I know I don’t have any other apps that use BLE devices - are there some common examples you’ve ran into?