[SOLVED] Flashing issues


#1

I’m having issues flashing new code to a Bluz DK this morning. Is there something going on? The Particle dashboard shows the flash started and flash/status success messages. The bluz blinks magenta and does it’s normal thing but when it reboots it has the old version. I’ve stripped my program down for testing, updating the version number for each attempt:

void setup() {
  Serial1.begin(38400);
  Serial1.println("Starting up Blank v1.1");
}

void loop() {
}

Before this issue started, probably an hour ago, I was getting instant flash failed messages on the Particle dashboard even though the Web IDE was reporting success. After that I tried rebooted the Gateway and did a factory reset on the Bluz though it took several attempts to get this program flashed.

At the moment I’m stuck in safe mode, it’s not accepting this program anymore. I’m stuck in the cycle of safe mode > flash above program > success reported via IDE & Dashboard > reboots into safe mode


#2

I’m not aware of any issues at the moment. When in Safe Mode, what version are you trying to compile from the Web IDE?

When you flash down a new app, does the RGB LED turn blue after the update is complete, but before it reboots?


#3

The web IDE has 1.1.47 chosen but I’ve been on that for a week now, I just tried with 1.0.47 with no difference. I don’t see blue afterwards and it’s unclear if it does reboot after the flash, it stays magenta the whole time, from slow to a long slow to fast, and then back to slow.

I have been seeing something odd lately, when to the factory reset it goes solid blue for a 1-2 sec and then blinks super fast blue, perhaps 30-50x a sec for roughly 7sec before the slow magenta, but some times it goes back to a slow blue blink before magenta again. I don’t think I’ve ever the super fast blue before, the LED is barely lit up so it might have been hard to see before.

After my latest flashing attempt I tried hitting the reset button afterwards. The first time it did a slow magenta for about a second then a fast magenta for about 5sec before going back to slow magenta. The next time it did 1sec of slow magenta and then probably 5sec of a fast blue before going back to slow magenta; every subsequent reset does this.

When I flash the particle dashboard shows the bluz as going offline about 5sec after the successful flash message and coming back online 5sec after that, then 2sec later is the module info and safe mode messages.

I see nothing abnormal in the debug output for the Gateway, looks like it’s sending and receiving data like it normally does.


#4

Can you try two things:

  1. What is the power supply you are using? Can you make sure if it is battery powered there is a good charge? Or power it off of a regulated source like a Photon?
  2. Can you switch to using the app? So instead of flashing with the gateway, complete unplug it and connect using the app and try to flash.

The magenta flashes are very confusing as it can mean multiple things. We have already cleared this up in 1.2 and it will be much easier to distinguish different states once we roll it out.


#5

:flushed: Whoops, my bad. I had it setup like shown here: http://docs.bluz.io/tutorials/serial/ but the 3v3 wire was one pin hole off and thus it didn’t actually have power connected. It must have somehow been pulling power from the RX/TX pins. The LED is much brighter now and flashing works properly. Thanks for your help.