[SOLVED] iOS app ALWAYS crashes after 5 seconds


#1

Right, I can’t do anything with this. I finally got around to trying to set it up and it doesn’t work.

Yes, I tried restarting the phone, I deleted and re-installed the app, I hard power cycled the Bluz and I did all of them at once (delete app, power down bluz, restart iPhone, install app, run app, power up bluz, hit connect, crash)

It comes on with a slow green flash. When I hit connect it does a fast green flash then connects with a cyan(ish) slow flash and appears (briefly) in the particle cloud as connected.
4 or 5 flashes later the app crashes and the Bluz disconnects.

EVERY SINGLE TIME.
Without fail.

I have the latest iOS 9.2.1 on an iPhone 6S and it just doesn’t work.


#2

I am sorry you are having issues. It sounds like perhaps the cloud connection from the app may be having issues. Are you logged in with your particle account? If so, can you log out and try again? If you were not, can you log in and try?


#3

I was logged in, but I logged out and quit the app. I closed it completely and restarted.
I logged in.
I powered on the Bluz, scanned, connected. waited and it crashed exactly as before.


#4

@eric, I have tested on the latest iOS but not on an iPhone 6s, only on a iPad Mini 2.


#5

I am using the latest on an iPhone 6 (Plus if that matters) and haven’t seen this for what it is worth. Just to hopefully help the troubleshooting process.

@Pyrofer not sure if it would/should affect anything but do you have any active bluetooth connections open to other devices?


#6

Can you completely close the app (double tap home and swipe up) and then try again but do not log back in?

I am running this on my iPhone 6s and don’t see an issue this long after a connection. Sometimes the app will crash upon connecting, but that happens almost immediately after you hit the Connect button. I haven’t seen it crash after it is connected to the cloud and that leads me to believe this has something to do with us polling the Particle cloud for the device name, this is about how long it takes after a connection.


#7

Also not seeing any issues with iOS 9.2.1 and iPhone 6s Plus, can flash Tinker and control it ok.


#8

Ok, so it turns out it was crashing as I hadn’t given the core a name in the particle cloud. When I set a name it worked.
I looked and the core connected, and at exactly the time it normally crashed the app instead the name of the core appeared in the app and it stayed working.

Now it won’t flash.

I click flash, it says flashing, says ok. But the core itself never flashes magenta like it’s meant to?


#9

That is odd, it shouldn’t require a name for the app not to crash, but I will take a look today.

Is it possible that you can send me the device ID? It is the long hex string shown in the app that starts with b1e2…

You can email it to me at hello@bluz.io or private message it to me on these forums by clicking on my name. once I have that, I can take a look. Thanks


#10

Message sent.
I worked out the “Not flashing” problem…
I was repeatedly flashing my Spark Core by accident instead of the Bluz. It flashes ok now I selected it.


#11

I just received a bluz and had the same problem. I had to name it in the particle cloud.
Also the workflow on the app is not polished yet :slight_smile: I had a hard time to figure out if the device was claimed or not.


#12

Yes, this is a known issue in the iOS app. We are definitely planning on some improvements to the apps in the (hopefully) not too distant future, so stay tuned!