[SOLVED] Particle.variable's will not update on one of my Bluz


#1

I have two Bluz, both of them running the same code and same firmware version. They both set the same Particle.variable’s for temperature, but one of them never get any values in the cloud.

As best as I can figure right now, maybe the gateway is mixing things up? It’s been running a lot longer than the devices have.

The CLI confirms the same results. But using the serial interface I can see that those variables do have values.

As an addition observation, I’ve seen the failing Bluz will reboot from time to time. The last time it was stuck with the D7 LED on while it restarted.

Woah! In tracking this down just now. I guessed that maybe the serial interface had something to do with the situation since the module that was not working was also connected via serial. So I disconnected the serial interface from TX/RX and suddenly the Particle.variables updated!? Why would the serial interface have anything to do with the Particle Variables??

Thanks for you help.


#2

Sounds like the issue is solved?

Without the code and wiring diagrams, it is hard to say why the Serial interface would have caused issues. Some possible thoughts off the top of my head:

  • Was the Serial code somehow blocking in the user app? This would interfere with cloud communication
  • Was the USB to Serial adapter 5V and not 3.3V? This could cause issues and possible damage to bluz
  • Was the USB to Serial adapter hooked up improperly?

Again, just sort of listing some possible issues, not sure what the real issue was.


#3

Currently I’m blaming the breadboard. Everything had to have been hooked up fine since the serial in/out were both working, the temp sensor communications were working, and the code didn’t change at all when it started to work. Only things changed were unplugging and replugging in wires in the same holes. I’ve been unable to recreate the situation, so yes, this one is closed.