Unable to Claim Bluz Chip


#1

I am trying to claim a Bluz chip being used by my team but I keep getting an error “Cannot Claim Device” on the android Bluz app. I have asked around and it does not look like anyone else claimed the device previously. I have tried the solution provided on the “[SOLVED]Cannot connect Bluz via Android Gateway App” thread but I am still getting the same error. I have also factory reset the device a few times. The device is currently blinking magenta once every ~2 seconds. I was wondering if I could get some help on how to go about claiming the device properly to avoid this error.


#2

Did the LED on the device flash cyan before you tried to claim it in the app? Are you sure you are using the newest version of the Android app from the Play Store?

The issue before was that the app simply stopped working and wouldn’t connect bluz to the cloud. A device cannot be claimed if it isn’t online. If it never flashed cyan, that sounds like your issue.


#3

Thank you for the reply. It never flashed cyan and I am currently using the latest version of the bluz app 1.1. I have also tried claiming the device both an android and an iPhone with the same results. The only other color I get is blue sometimes when it is connected to the app. I never got a cyan color.


#4

Can you send me the first 8 characters of the device ID? So it should be b1e2WXYZ where WXYX are hex characters.

Also, just to verify, all the devices have a proper internet connection? And you’re not behind a firewall or other system which could block outward access to some ports or IP addresses?


#5

These are the first 8 characters “b1e2ffff”. Also I do not think there is a firewall blocking the connection because I have a photon chip connected via the same network.


#6

I have the same problem like you and ordered a ST-Link V2 to reprogram my Bluz
It looks like the external SPI flash got corrupted and I have really no idea why. I did not use my BluzDKs for several weeks until I found that out.
I always thought that it is the Android app which crashes and freezes everytime the screen of my phone goes off.